Commit 431f2dd9 authored by Chris Cantwell's avatar Chris Cantwell

Fix for using ErrorUtils in executables which do not support MPI.

parent f3f69939
......@@ -47,8 +47,6 @@ IF( NEKTAR_USE_MPI )
UNSET(HAVE_APRUN CACHE)
ENDIF()
ADD_DEFINITIONS(-DNEKTAR_USE_MPI)
IF (THIRDPARTY_BUILD_GSMPI)
EXTERNALPROJECT_ADD(
gsmpi-1.2
......
......@@ -411,6 +411,7 @@ ENDIF()
# MPI
IF( NEKTAR_USE_MPI )
TARGET_LINK_LIBRARIES(LibUtilities LINK_PRIVATE ${GSMPI_LIBRARY} ${XXT_LIBRARY})
TARGET_COMPILE_DEFINITIONS(LibUtilities PUBLIC "-DNEKTAR_USE_MPI")
IF (NOT MPI_BUILTIN)
TARGET_LINK_LIBRARIES(LibUtilities LINK_PUBLIC ${MPI_LIBRARY} ${MPI_EXTRA_LIBRARY})
SET_TARGET_PROPERTIES(LibUtilities
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment