Commit c0b23102 authored by Dave Moxey's avatar Dave Moxey

Merge branch 'fix/pkg-deb-dep-openmpi' into 'master'

Fix missing dependency on openmpi-bin for DEB packages.

This MR fixes the missing openmpi-bin dependency, which is required for packaged executables to run (even in serial without mpirun).

See merge request !630
parents cfa53902 36471b99
......@@ -6,6 +6,9 @@ v4.3.2
**Library**:
- Add small optimisation for DriverAdaptive (!618)
**Packaging**:
- Fixes for DEB package dependencies (!630)
v4.3.1
------
**Library**:
......
......@@ -54,6 +54,8 @@ if (NEKTAR_BUILD_UTILITIES)
endif()
if (NEKTAR_BUILD_LIBRARY AND DPKG)
set(NEK_DEP "openmpi-bin")
### DEBIAN PACKAGES ############################################
# Note that the formatting of the DESCRIPTION field is VERY specific. It
# must start with a new line, each line must start with a space, and there
......@@ -65,8 +67,9 @@ if (NEKTAR_BUILD_LIBRARY AND DPKG)
DESCRIPTION "
This library provides core routines including linear algebra and integration
with ThirdParty libraries."
DEPENDS "${NEK_DEP}"
INSTALL_LIBS "${libnektar++-utilities_LIBS}")
set(NEK_DEP "libnektar++-utilities (= ${NEKTAR_VERSION})")
set(NEK_DEP "${NEK_DEP}, libnektar++-utilities (= ${NEKTAR_VERSION})")
add_nektar_package(
NAME libnektar++-stdregions
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment